Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Error in Channel Setup

  1. #1
    Join Date
    Feb 2012
    Location
    Ellington, CT USA
    Posts
    112

    Error in Channel Setup

    Am using the TV listings plug in for some time with no operational errors except that one channel never has any info listed in the TV Listings channel guide screen. However the channel can be viewed live okay.

    While troubleshooting that problem I deleted the channel from the channel list and attempted to add it back. However I then found that I could not map the channel OR even show the "Channel Details" for ANY of the listed channels. I get an error that says " Unhandled exception has occurred in a component in your application ... Visual Styles-related operation resulted in an error because no visual style is currently active. " when I try to check any channel details.

    I started a fresh run of NextPVR and zipped the logs (and a txt file of the error info) to attach here.

    Note that the TV Listing plug-in has been (and still does) work okay for the last several months. I only noticed this error while in the setup application the other day while trying to fix that one channel listing problem.

    Also I tried to revert to the stock "TV Guide" instead of the "TV Listing" plugin and the stock TV Guide no longer works at all giving me a channel screen with no details plus errors.
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,964
    I'm mot really sure what that error means. Have you tried rebooting?

    You're not running Win10 with one of those hacks to enable Aero?

  3. #3
    Join Date
    Feb 2012
    Location
    Ellington, CT USA
    Posts
    112
    Nope .. still running Windows 7 Pro 32-bit. While troubleshooting this I have re-booted the computer several times. No joy there. I'm getting ready to build a new HTPC which will be a Win 10 Pro 64 bit unit.

    Maybe it's time to finally shut down this small HTPC and get started on the new one? But I'm not there yet and will need to use this old HTPC for another couple months.

    I "used" to be able to switch between the stock TV-guide and the TV-Listing plugin replacement while testing etc. But now only the TV Listing plug in works and the stock TV-Guide is broken. My un-educated guess is that this is a Windows graphics thing.

    One line in the error report says, " System.InvalidOperationException: Visual Styles-related operation resulted in an error because no visual style is currently active " I think something in the Windows system has screwed up. What is the "visual style" thing that is not active ??

    This problem only showed up when I needed to fix a channel problem and found I can not do any channel editing etc. without getting that error. The whole system has been working flawless for many months and still is working fine .. except I can't work with any of the channels in "Settings". This problem may have been in place for months without me noticing.

    I wonder if or how I could re-install NextPVR and keep all the settings in place? Hopefully to get everything back to the original format using the stock TV-Guide without any plug-ins. If that doesn't work then I'm thinking there is something amiss with my Windows system ??

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,964
    What error do you get with the stock TV Guide? I can't see anything in your logs.

  5. #5
    Join Date
    Feb 2012
    Location
    Ellington, CT USA
    Posts
    112
    Busy recording night here. In about 5 minutes all recordings should be ended and I'll switch from the TV Listing plug in to the stock Guide and send you a screen shot and the current logs. Sorry the other log I sent earlier didn't have any examples of my trying to use the original TV Guide. Logs to follow in a few minutes.

  6. #6
    Join Date
    Feb 2012
    Location
    Ellington, CT USA
    Posts
    112
    Attached are 3 screen caps showing the error when trying to run Nextpvr with the stock TV Guide enabled along with the resultant "empty" TV Guide screen caused by the error and what the working TV Listing screen looks like (which works and looks okay).

    Also the logs including switching between the two.
    Attached Files Attached Files

  7. #7
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,964
    I suspect that might be to do with the skin. Can you see if switching to the default skin helps?

  8. #8
    Join Date
    Feb 2012
    Location
    Ellington, CT USA
    Posts
    112
    Quote Originally Posted by sub View Post
    I suspect that might be to do with the skin. Can you see if switching to the default skin helps?
    Tried default skin as well as a few others. No joy. All skins produce the same error in only the original TV Guide GUI and the Plugin TV Listing GUI is still perfect.

    Several months ago you helped me make a mod to one of the config files to increase the number of rows in the stock TV Guide. That worked fine. However for some reason (which I don't remember) I switched to the TV Listing plug in.

    As I mentioned since that mod I have been able to switch between the two guides without problems. Have been using the TV Listings plugin for maybe a month or two, when the other day tried to switch back to the stock TV Guide when this problem cropped up. I wonder if that config file that we modded might have been glitched or corrupted? If one of the variables concerning the TV Guide GUI is corrupted maybe that would create this error ? It's trying to use a variable in the config.xml file that is out of range or something maybe ?? I'll take a look at those config files and see if I can find anything amiss.

    Oh just had a thought .. I only recently upgraded to the latest version of NPVR. Could the new version of NPVR have a problem with the values we changed in the config file ?

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,964
    You might have screwed the C:\Users\Public\NPVR\Skin\Default\TV Guide\guide.xml when you where tweaking the skin files. Maybe delete the file and reinstall.

  10. #10
    Join Date
    Feb 2012
    Location
    Ellington, CT USA
    Posts
    112
    Okay .. will do tomorrow morning. Sun will be coming up in about 4 hours. Best to tackle this after I get some sleep.
    <grin> Thanks for the help ... Hope your holiday was great !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •