Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: No EPG data/live TV in Kodi

  1. #11
    Join Date
    Nov 2012
    Location
    USA
    Posts
    10
    Quote Originally Posted by mvallevand View Post
    The shields are getting logged in but I am not seeing how. Empty their pvr guides shut them down and shutdown the iOS device too. Then restart the server and bring one shield online and we can see clean logs.

    Martin
    Ok - I am on a different shield now. I'm not sure what the iOS device was - but hopefully it's not in the logs now.

    I added a username in NVPR settings (under the client tab). I also have a password and a pin that was previously set. Once I added the user name, the guide process completed ( I can see channels in my EPG where I couldn't before), but I dont' see whats actually on at specific times. I do not specify this username/password/pin in Kodi - so I'm not sure why this made any difference. So this issue has changed a bit, but still persists.

    Also - when I attempt to open a channel, the stream fails. It looks like a 404 error, but again, I can watch this on other Kodi clients without fail. If it were a true 404, then I would think they would all fail.

    I've attached new logs for Kodi and NPVR. Again - really appreciate your time looking into this!
    Last edited by nate5532; 2019-08-03 at 07:07 PM.

  2. #12
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,889
    I would need the kodi log from the shield not the PC this afternoon. There is a good addon for Kodi that uploads the log to pastebin and you can just send us the URL.

    I think you need to find the patch for NShared to avoid transcoding but there is another odd error. Maybe this one https://forums.nextpvr.com/showthrea...240#post533240 but there might be a newer one.

    2019-07-08 21:20:26.697 [DEBUG][3] Failed to build IPTV graph: Unable to locate 'NPVR Net Push Source'

    Also earlier when you tried to play a file you got one of hese

    2019-07-08 21:13:53.887 [DEBUG][25] Doing second chance 401...

    so the problem was also at the source.

    Martin
    Last edited by mvallevand; 2019-07-09 at 02:00 AM.

  3. #13
    Join Date
    Nov 2012
    Location
    USA
    Posts
    10
    Quote Originally Posted by mvallevand View Post
    I would need the kodi log from the shield not the PC this afternoon. There is a good addon for Kodi that uploads the log to pastebin and you can just send us the URL.

    I think you need to find the patch for NShared to avoid transcoding but there is another odd error. Maybe this one https://forums.nextpvr.com/showthrea...240#post533240 but there might be a newer one.

    2019-07-08 21:20:26.697 [DEBUG][3] Failed to build IPTV graph: Unable to locate 'NPVR Net Push Source'

    Also earlier when you tried to play a file you got one of hese

    2019-07-08 21:13:53.887 [DEBUG][25] Doing second chance 401...

    so the problem was also at the source.

    Martin
    Hey Martin -
    Thanks for all of your help! I haven't had a chance to play with this lately. I turned on KODI and everything is now working. I'm not sure what happened, but I'll take it!

    Thanks again

  4. #14
    Join Date
    Nov 2012
    Location
    USA
    Posts
    10
    Hi Martin -

    Well... I may have spoke too soon. The guide loads up perfectly on my Nvidia Shield client, but now when I try to watch live TV, I can see a quick flash at the top of the screen and then it doesn't want to go.

    Side note - recordings that I made on my PC that is hosting NPVR will play fine in Kodi on the Shield. I'm not sure why live TV is not cooperating.

    I also downloaded the Nshared.dll and put it in my C:\Program Files (x86)\NPVR folder.

    Thanks again for all of your help!

    Kodi pastebin: https://paste.kodi.tv/ikofazedac

    NPVR logs attached too
    Attached Files Attached Files
    Last edited by nate5532; 2019-08-03 at 07:45 PM.

  5. #15
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,889
    I see 404 errors in Kodi there the tuner could be in use or perhaps you redid the channels and Kodi is not in sync

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •