Results 1 to 3 of 3

Thread: Settings not being saved after shutdown

  1. #1
    Join Date
    Jul 2019
    Location
    Sterling Heights Mi
    Posts
    2

    Settings not being saved after shutdown

    i'm running V5 on an Asus Chromebox with LibreELEC 9.1.001 (kernel:Linux 5.1.9) and Docker, with a Western Digital external harddrive. Everything works fine but when I shutdown or reboot I lose all of the settings.
    To get it to work I had to SSH into it and use the following settings:

    docker run -d \
    > --volume /storage/pi/config:/config \
    > --volume /var/media/sdb1-ata-WDC_WD5000AAKB-0/videos:/recordings \
    > --volume /var/media/sdb1-ata-WDC_WD5000AAKB-0/videos:/buffer \
    > --publish 8866:8866 \
    > nextpvr/nextpvr_amd64:latest

    I'm fumbling my way through this as I have no experience with Docker and minor use of Linux. I'm guessing that there's something wrong with the config location, but I'm lost after that.
    Any help would be appreciated and thanks in advance.
    Attached Files Attached Files

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Posts
    29,134
    I use simply /storage/config since there is no /storage/pi folder by default in LE and I just had to create one level.

    Did you create your two folders first using something like

    mkdir -p /storage/pi/config

    Also the folder needs to exist before you start docker

    Martin

  3. #3
    Join Date
    Jul 2019
    Location
    Sterling Heights Mi
    Posts
    2
    No I didn't create the folders before starting Docker. I thought that's what the volume command did.
    So I should remove everything,create the storage/config then start Docker? I'll give that a try.
    Thanks for the quick response. It's a learning experience .. a little frustrating sometimes, but interesting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •