Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Recording Issues

  1. #1
    Join Date
    Jan 2004
    Location
    Vinita, OK
    Posts
    261

    Recording Issues

    I was checking on it progress with multiple back to back recording only find that crash

    ● nextpvr-server.service - NextPVRServer
    Loaded: loaded (/usr/lib/systemd/system/nextpvr-server.service; enabled; vendor preset: enabled)
    Active: failed (Result: signal) since Fri 2019-08-09 16:02:04 CDT; 1h 43min ago
    Process: 1515 ExecStart=/opt/nextpvr/shell/server.sh start (code=exited, status=0/SUCCESS)
    Main PID: 1519 (code=killed, signal=ABRT)

    Aug 09 16:01:40 shspvr-game server.sh[1515]: at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byt
    Aug 09 16:01:40 shspvr-game server.sh[1515]: at System.Net.WebClient.UploadString(Uri address, String method, String da
    Aug 09 16:01:40 shspvr-game server.sh[1515]: at NShared.LocalRecorder.StartStream(ChannelMapping channelMapping, String
    Aug 09 16:01:40 shspvr-game server.sh[1515]: at NShared.RecordingService.WorkerThread()
    Aug 09 16:01:40 shspvr-game server.sh[1515]: at System.Threading.Thread.ThreadMain_ThreadStart()
    Aug 09 16:01:40 shspvr-game server.sh[1515]: at System.Threading.ExecutionContext.RunInternal(Exec utionContext executio
    Aug 09 16:01:40 shspvr-game server.sh[1515]: --- End of stack trace from previous location where exception was thrown ---
    Aug 09 16:01:40 shspvr-game server.sh[1515]: at System.Runtime.ExceptionServices.ExceptionDispatch Info.Throw()
    Aug 09 16:02:04 shspvr-game systemd[1]: nextpvr-server.service: Main process exited, code=killed, status=6/ABRT
    Aug 09 16:02:04 shspvr-game systemd[1]: nextpvr-server.service: Failed with result 'signal'.
    ~

    I add some screenshot and log any though sub ?.
    Attached Images Attached Images   
    Attached Files Attached Files

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Posts
    29,142
    That's cool that the service status command trapped the stdout that wasn't logged. I would not have thought about that. Just a note that if you make your ssh terminal window wider you would see more text that got truncated in that capture.

    Martin

  3. #3
    Join Date
    Jan 2004
    Location
    Vinita, OK
    Posts
    261
    I think I know going on here I think it because of Pre-Padding Post-Padding and it change channel to due to lack of tuner


    nextpvr-server.service - NextPVRServer
    Loaded: loaded (/usr/lib/systemd/system/nextpvr-server.service; enabled; vendor preset: enabled)
    Active: failed (Result: signal) since Fri 2019-08-09 19:01:42 CDT; 2min 10s ago
    Process: 15606 ExecStart=/opt/nextpvr/shell/server.sh start (code=exited, status=0/SUCCESS)
    Main PID: 15608 (code=killed, signal=ABRT)

    Aug 09 19:01:41 shspvr-game server.sh[15606]: at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)
    Aug 09 19:01:41 shspvr-game server.sh[15606]: at System.Net.WebClient.UploadString(Uri address, String method, String data)
    Aug 09 19:01:41 shspvr-game server.sh[15606]: at NShared.LocalRecorder.StartStream(ChannelMapping channelMapping, String target, String& reason)
    Aug 09 19:01:41 shspvr-game server.sh[15606]: at NShared.RecordingService.WorkerThread()
    Aug 09 19:01:41 shspvr-game server.sh[15606]: at System.Threading.Thread.ThreadMain_ThreadStart()
    Aug 09 19:01:41 shspvr-game server.sh[15606]: at System.Threading.ExecutionContext.RunInternal(Exec utionContext executionContext, ContextCallback callback, Object state)
    Aug 09 19:01:41 shspvr-game server.sh[15606]: --- End of stack trace from previous location where exception was thrown ---
    Aug 09 19:01:41 shspvr-game server.sh[15606]: at System.Runtime.ExceptionServices.ExceptionDispatch Info.Throw()
    Aug 09 19:01:42 shspvr-game systemd[1]: nextpvr-server.service: Main process exited, code=killed, status=6/ABRT
    Aug 09 19:01:42 shspvr-game systemd[1]: nextpvr-server.service: Failed with result 'signal'.

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    91,132
    I'm a bit short on time today, but I'll try to reproduce it tomorrow.

  5. #5
    Join Date
    Jan 2004
    Location
    Vinita, OK
    Posts
    261
    Quote Originally Posted by sub View Post
    I'm a bit short on time today, but I'll try to reproduce it tomorrow.
    With HVR-2250 dual tuner only installed
    I set Pre-Padding to 0 and Post-Padding also to 0 and it keep right on going never crashing after 4 hours so I sure that also affect Windows as well
    So look like it need some improvement made to Intelligent Recording in this area

  6. #6
    Join Date
    Jan 2004
    Location
    Vinita, OK
    Posts
    261
    was you able to reproduce it sub ?.

  7. #7
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    91,132
    Sorry, been snowed under with day-job stuff the last few days, so haven't had a chance to look at it yet.

  8. #8
    Join Date
    Jan 2004
    Location
    Vinita, OK
    Posts
    261
    Ok

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    91,132
    FYI - I spent quite a bit of time the last couple of days trying to reproduce this issue, with different types of back to back recordings, but wasn't able to. I have however now added disk logging for DeviceHostLinux, so I should be able to get you to reproduce the issue, and supply the logs. Hopefully this will give me enough information to get to the bottom of it.

    I'm intending to do a new release today or tomorrow, which will including that extra logging. I wont make you wait another couple of weeks for a fix though - I'll get on with a fix as soon as you can supply the logs showing the error.

  10. #10
    Join Date
    Jan 2004
    Location
    Vinita, OK
    Posts
    261
    Quote Originally Posted by sub View Post
    FYI - I spent quite a bit of time the last couple of days trying to reproduce this issue, with different types of back to back recordings, but wasn't able to. I have however now added disk logging for DeviceHostLinux, so I should be able to get you to reproduce the issue, and supply the logs. Hopefully this will give me enough information to get to the bottom of it.

    I'm intending to do a new release today or tomorrow, which will including that extra logging. I wont make you wait another couple of weeks for a fix though - I'll get on with a fix as soon as you can supply the logs showing the error.
    Ok look forward to it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •